Getting Data In

splunk syndication input do not show

pipipipi
Path Finder

I want to monitor AWS service status using splunk.
So, I installed syndication input.

I set up RSS, and I can check this input is success.

index=_internal sourcetype= "syndication_modular_input"
return
"INFO Successfully retrieved feed entries, count=0" url ="****"

but, when I search sourcetype=syndication, there is no event.
(my sourcetype is default)

I do not know why I can see event in search.
Could you please help me?

Tags (2)
0 Karma
1 Solution

DavidHourani
Super Champion

Hi @pipipi,

Did you check in index=main ? Looking at the inputs of this app no index is defined for the input stanza, by default data will go to the default index.

You should change that to the desired index in yourapp/local/inputs.conf.

Cheers,
David

View solution in original post

pipipipi
Path Finder

Thank you for helping.

I set the source index.
but I can not see event.

I do not understand why my input is not index.....

0 Karma

DavidHourani
Super Champion

Hi @pipipi,

Did you check in index=main ? Looking at the inputs of this app no index is defined for the input stanza, by default data will go to the default index.

You should change that to the desired index in yourapp/local/inputs.conf.

Cheers,
David

DavidHourani
Super Champion

If you read the line : "INFO Successfully retrieved feed entries, count=0" url =""seems like there is no configured url. Have you tried setting this up ?

0 Karma

pipipipi
Path Finder

I did not write url because of question.
I'm sorry.
My splunk shows url.

0 Karma

DavidHourani
Super Champion

Could you enable debugging and try this :
https://lukemurphey.net/projects/splunk-syndication-input/wiki/Troubleshooting

You should get more info about what's blocking the data.

0 Karma

pipipipi
Path Finder

My trouble is internet access.
I saw this question.
https://answers.splunk.com/answers/246725/use-a-proxy-server-for-internet-access.html

I wrote proxy in splunk-launch.conf, but I can not connect internet.

0 Karma

DavidHourani
Super Champion

Hi @pipipi,

follow this tutorial, it will help :
https://blog.infusiontechsolutions.com/how-to-configure-splunk-to-use-a-web-proxy-server/

It's probably best to set up the proxy in /etc/init.d/splunk

# Proxy settings
http_proxy="http://proxy.domain.com:8080"
export http_proxy

That way its always up when Splunk boots on startup.

0 Karma

pipipipi
Path Finder

I did export and I can see event in splunk.
Thank you for helping me.

0 Karma

DavidHourani
Super Champion

you are most welcome, please upvote and accept the answer 🙂

And don't forget to save your config in the startup script or the export won't be there after restart.

Cheers.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...