Getting Data In
Highlighted

repFactor is not set to auto docker-splunk image

New Member

Hi all,
I'm working on deploying index clustering in kuberntes using docker-splunk image and faced with the following issue:
By default on indexers when you configure cluster indexing repFactor is set to 0 what prevent replication between indexers. Should this be fixed in the nearest time or better to fix by your own?
I'm interested,how people who faced with it resolved this issue?

0 Karma
Highlighted

Re: repFactor is not set to auto docker-splunk image

Influencer

Attribute repFactor is set during index configuration. By default it is set to 0. You need to change it to auto when you create an index.

0 Karma
Highlighted

Re: repFactor is not set to auto docker-splunk image

New Member

It's applies to traditional deployment of Splunk, I'm talking about splunk in docker.

0 Karma
Highlighted

Re: repFactor is not set to auto docker-splunk image

New Member

You can't set this param in UI and setting this param on every indexer sounds odd,especially when there is an ansible role that should configure all indexers as a cluster.

0 Karma
Highlighted

Re: repFactor is not set to auto docker-splunk image

Motivator

You are correct. The default value for repFactor is zero, which means no replication.
If you omit the parameter from indexes.conf, that is the value you get, and no replication.
You need to explicitly set the value at either the global, or per index level within indexes.conf to override the default.

https://docs.splunk.com/Documentation/Splunk/8.0.2/Indexer/Configurethepeerindexes#The_indexes.conf_...

0 Karma