Getting Data In

props.conf is not working in MyApp01 folder but it's working in search folder

MuratKuru
Explorer

Hi All
My props.conf is not working if placed under "C:\Program Files\Splunk\etc\apps*MyApp01\local\" bu if I copy the file to "C:\Program Files\Splunk\etc\apps**search*\local".
Why is that?

0 Karma

richgalloway
SplunkTrust
SplunkTrust

It sounds like you're trying to change a setting that is defined in the search app. Know that config files are processed in alphabetical order by app name so 'search' will take precedence over a later name such as 'thisismyapp'. The solution is to change your app to come before 'search'.

You can use splunk btool --debug props list to detect this situation before restarting Splunk.

---
If this reply helps you, Karma would be appreciated.

MuratKuru
Explorer

Hi richgalloway
Thank you for your reply.
The name of my app is before the search up, but that it's still now working.
Any other idea?

0 Karma

richgalloway
SplunkTrust
SplunkTrust

What setting(s) are you trying to change? Have you used btool to see where the setting is defined?

---
If this reply helps you, Karma would be appreciated.
0 Karma

to4kawa
Ultra Champion
0 Karma
Get Updates on the Splunk Community!

Observability Highlights | January 2023 Newsletter

 January 2023New Product Releases Splunk Network Explorer for Infrastructure MonitoringSplunk unveils Network ...

Security Highlights | January 2023 Newsletter

January 2023 Splunk Security Essentials (SSE) 3.7.0 ReleaseThe free Splunk Security Essentials (SSE) 3.7.0 app ...

Platform Highlights | January 2023 Newsletter

 January 2023Peace on Earth and Peace of Mind With Business ResilienceAll organizations can start the new year ...