Getting Data In

input type="time"

sondradotcom
Path Finder

I'm using

<input type="time">

in my form, but I can't figure out how to make the subsequent tables actually "hear" the time range. They seem to default to looking at the entire set of data regardless of what the time pulldown is set to. Any thoughts?

-S.

Tags (1)
0 Karma

sondradotcom
Path Finder

I can't seem to get it to not parse some of this, but hopefully you get the right idea.

    <form> <label>Live Stream Form</label>


    <fieldset>
        <input type="dropdown" token="Streamname"> <choice value="*">All Streams</choice> <populatingSearch fieldForValue="Streamname" fieldForLabel="Streamname">| inputlookup Streams | dedup Streamname | sort Streamname</populatingSearch> </input>

<input type="time">
        <default>Last 7 days</default>
      </input>   </fieldset> <row> <single>
    <searchTemplate>index=summary search_name="si_flashlive_filename" Streamname="$Streamname$"  | stats count | eval count = tostring(count,"commas")</searchTemplate> <title>Total Requests</title> </single> </form>

Ayn
Legend

Hard to say anything without seeing the whole form. Could you paste the code for the whole form, please.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...