Getting Data In

Your entry was not saved. The following error was reported: SyntaxError: Unexpected token < in JSON at position 0.?


Reproduce the error:
1. Export the results of a previous search job (a table with 22 fields and 32k+ rows) as a CSV.
2. Attempt to upload CSV as a new lookup file with CSV filetype selected.

Why do I get this error? I've seen error messages similar to this for other peoples' questions but I have not seen any where the issue comes from trying to upload a CSV as a lookup file.

Labels (1)
0 Karma

Loves-to-Learn Lots

Did you ever figure out how to resolve this error? I'm currently having the same issue. @russell120 

0 Karma


I have seen this error when my authentication to Splunk has expired.

When I reauthenticate, the error has gone away.

0 Karma


It sounds like it's trying to ingest the file as a json rather than as a csv. Perhaps somebody touched the file with Excel and Microsoft converted it?

First, verify that the file is, in fact, a plain csv down on the box, by attempting to edit it with a vanilla editor (notepad++ or something like that).

Second, step through the upload one item at a time and read every instruction or message. This sounds vaguely familiar, and I'm pretty sure it's just either the file has been altered or an option that went wonky.

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...