Getting Data In

Windows Event Log Sub-Search to filter for users RDPing with specific accounts

hubbardw
New Member

So here's the issue... We have an RDS Farm that users login to and from there they RDP to other servers. Right now I have a search that creates a table and shows the users that are logging in with non-domain accounts/service accounts from the jump servers(RDS Farm) to the other servers -

index="wineventlog" source="WinEventLog:Security" EventCode=4624 Process_Name="*winlogon*" NOT (user=Example_AdminAccounts) NOT (Account_Domain=Example_Domains)
| table _time, dst_nt_domain, user, ComputerName, src_ip
| convert timeformat=" %A, %h-%d %Y %H:%M:%S%P" ctime(_time)
| rename user as "User", ComputerName as "FQDN", src_ip as "Source IP", name as "Description", dst_nt_domain as "Domain", _time as "Date and Time"

This search works properly, however I am trying to create a subsearch that would give me the following:

If a user field includes

  • user=svc_account

then search the

  • hosts=RDS Jump Server Farm within

    • WinEventLogs:Application=Microsoft-Windows-TerminalServices-RDPClient/Operational
    • EventCode=1024 for matching
    • ComputerName from previous search results and
    • Output table with fields=_time, SubSearched_User, OriginalSearch_User, OriginalSearch_ComputerName
    • Rename _time as Date and Time, SubSearched_User as User, OriginalSearch_User as Service Account, OriginalSearch_ComputerName as FQDN.

I'm not sure if this is possible or if there's a better method to go about this but hopefully some of you experts can lend a hand.

Any help would be greatly appreciated.

Thanks!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Deep Dive: Accelerate threat investigation with Splunk’s AI Assistant in Security

AI is one of the biggest topics in the market today, and for security teams, its value goes far beyond the ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Detection Engineering Office Hours: Real-World Troubleshooting & Q&A

[REGISTER HERE] This thread is for the Community Office Hours session on Detection Engineering Office Hours: ...