Getting Data In
Highlighted

Why is universal forwarder installation failing with error "Could not bind to port 8089" using the deployment server option hostname:port (8089)?

New Member

Installing universal forwarder is failing because it cannot bind to TCP 8089.

My understanding of TCP communications is this:
Client reaches out to destination server via a dynamic TCP Port to a destination TCP port which is static. (server is listening on static port 8089)

If that is accurate:
When installing the universal forwarder on a client and using the deployment server option hostname:port (8089), why is the install failing because a process already has the 8089 port in use (on the client).

If my understanding is correct, then the client shouldn't care if it already has a process listening on TCP 8089 because when it reaches out to the indexer hostname:8089 it will be sourcing from a dynamic tcp port.

Bottom line, I cannot get the universal forwarder because w3wp.exe is already using 8089 on my client and I cannot change it.

Thanks in advance for any help.

FROM SPLUNKD.LOG

06-16-2016 15:37:27.372 -0500 FATAL HTTPServer - Could not bind to port 8089
0 Karma
Highlighted

Re: Why is universal forwarder installation failing with error "Could not bind to port 8089" using the deployment server option hostname:port (8089)?

Builder

You can always disable port 8089 if you don't intend to remotely manage the Universal Forwarder.

http://docs.splunk.com/Documentation/Splunk/6.4.1/admin/Serverconf

See the section for disableDefaultPort

View solution in original post

0 Karma
Highlighted

Re: Why is universal forwarder installation failing with error "Could not bind to port 8089" using the deployment server option hostname:port (8089)?

New Member

Wow thanks for the prompt reply.
I saw that, but that is post install though.

It wont install because the server is using 8089.
I tried installing it with a different port for the distribution server but it didnt work.

Any ideas on how to install it with a different port or disabled?

0 Karma
Highlighted

Re: Why is universal forwarder installation failing with error "Could not bind to port 8089" using the deployment server option hostname:port (8089)?

Builder

Ah sorry about that! During the initial install you should be able to set a number of different parameters like SPLUNKD_PORT. Take a look at the following doc:

http://docs.splunk.com/Documentation/Splunk/6.4.1/Installation/InstallonWindowsviathecommandline

Highlighted

Re: Why is universal forwarder installation failing with error "Could not bind to port 8089" using the deployment server option hostname:port (8089)?

New Member

Sorry for the delay - i was able to use the install switch and use a different port on the source port side. Working great.
Thanks!

0 Karma
Highlighted

Re: Why is universal forwarder installation failing with error "Could not bind to port 8089" using the deployment server option hostname:port (8089)?

Ultra Champion

Something is weird here because the logging of the installation goes to /splunkforwarder/var/log/splunk/first_install.log and upgrades of the forwarder would go to migration.log.<date> and then when the product comes up the logging goes to splunkd.log.

When the installation is complete, the deployment server configuration is at /splunkforwarder/etc/system/local/deploymentclient.conf, which can be changed.

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.