Getting Data In

Why is the Windows perfmon data in Splunk for percentage processor time different from the performance counter value on the server?

shreyasathavale
Communicator

I have this Splunk stanza below:

[perfmon://CPUTime]
interval = 30
object = Processor
counters = % Processor Time
instances = _Total
disabled = 0
index = perfmon

When I run this search, I get a result of around 50+%

index = perfmon ( datacenter="iad" ) ( environment="prod" ) ( host="ms10191" ) ( counter="% Processor Time" ) ( instance="_Total" ) | eval name=host+"-"+counter+"-"+instance | timechart avg(Value) by name

But when I check through the Performance Counter on the server, I am getting a value around 15-20%

Is splunk showing wrong data?

Tags (3)

s2_splunk
Splunk Employee
Splunk Employee

Are the time spans that you are averaging over in your Splunk search the same than the sampling periods configured in Perfmon for your Windows hosts? If those don't match, one would expect the results to be different, no? Note that you are pulling Perfmon data every 30 seconds.

0 Karma

bpitts2
Path Finder

I know this is old, but I was hoping you may have found an answer. I'm also observing different returned values in splunk than what is in perfmon local to the server.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...