Getting Data In

Why is my deployment client showing as disabled and says splunkd needs to be up, but it already seems to be?

Path Finder

I'm troubleshooting a deployment client and I've gotten stuck;

Deploy server
$ /splunk/bin/splunk --version
Splunk 6.1.4 (build 233537)
Note: This server deploys apps successfully to 125+ clients.

Deploy client
$ /opt/splunkforwarder/bin/splunk --version

Splunk Universal Forwarder 6.1.5 (build 239630)

The problem; no deployments.

$ /opt/splunkforwarder/bin/splunk display deploy-client
Deployment Client is disabled.
This command [GET /services/messages/restart_required/] needs splunkd to be up, and splunkd is down.

$ service splunk status
Splunk status:
splunkd is running (PID: 4922).
splunk helpers are running (PIDs: 4923).

Other than the obvious need to upgrade, does this indicate a glaring mistake I'm missing or is this more subtle? Currently setting up log debugging to see if I can learn more.

Thanks.

0 Karma
1 Solution

Path Finder

Sorted it out. Client config had a missing parameter.

View solution in original post

0 Karma

New Member

What was the solution @pipegrep?

0 Karma

Legend

The error message

This command [GET /services/.....] needs splunkd to be up, and splunkd is down.

could mean that splunkd is down, but it almost always means

"There was a syntax error in your command and the CLI was not smart enough to throw a decent error message. Or maybe splunkd didn't return a decent error code for the CLI to report back to you."

Basically - there is a typo.

Path Finder

Sorted it out. Client config had a missing parameter.

View solution in original post

0 Karma