Getting Data In
Highlighted

Why do we have SSL issues after installing a Splunk Universal Forwarder?

Explorer

Installed Splunk forwarder 6.6.2 on an OpenStack controller node using the rpm package. We are now having problems with SSL certificates when going into Horizon. We are using Red Hat's OSP 10 (triple O) environment, which has RHEL 7.3 on the controller.

1) Does installing the splunkforwarder rpm change anything with the SSL environment?
2) The first time you launch the forwarder by type ./splunk start, does that change the SSL environment?

Thank you,
Alan

0 Karma
Highlighted

Re: Why do we have SSL issues after installing a Splunk Universal Forwarder?

Esteemed Legend

Only if your stuff was stored (or linked) in /opt/splunk/ which would be absurd.

0 Karma
Highlighted

Re: Why do we have SSL issues after installing a Splunk Universal Forwarder?

Path Finder

can you please add what SSL issue you are observing?

0 Karma
Highlighted

Re: Why do we have SSL issues after installing a Splunk Universal Forwarder?

Explorer

So, the issue here turned out to be a colleague installed Tasker at the same time the Universal Forwarder was installed. The pip removal of the Tasker application resolved the SSL issue with OpenStack Horizon.

Thank you to all who helped with this.

View solution in original post

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.