Getting Data In

Why do I receive SSL alert number 40 with selfsigned certificates?


Dear all,

We are on process of ingesting Check Point EDR logs in our Splunk Cloud Platform. This should be done through a Heavy Forwarder. Checkpoint sends encrypted data to HFW.

For that purpose, we used the following guide provided by CheckPoint for generating and configure the certificates which contains specific instructions for Splunk:

As summary, there are two certificates that needs to be configured on the Splunk side: 

- splunk.pem It is a combination of SyslogServer.crt + SyslogServer.key + RootCa.pem configured in /opt/splunk/etc/apps/CheckPointAPP/local/inputs.conf
- ca.pem configured in /opt/splunk/etc/system/local/server.conf

This configuration is not working because the certificate splunk.pem is giving a handshake error "SSL alert number 40".

The following setting in server.conf as the CheckPoint guide specifies, returns an error in Splunk: "Invalid key in stanza [SSL]".



cipherSuite = TLSv1+HIGH:TLSv1.2+HIGH:@STRENGTH


We also have tried with this configuration with the same result:






In Splunk internal wereceive the following error:


Received fatal SSL3 alert. ssl_state='SSLv3 read client certificate A', alert_description='unknown CA'.


Do you know which could be the point of failure? Why the certificate is returning an error 40 or if the configuration should be set in a different way?

Best regards

Tags (1)
0 Karma
Get Updates on the Splunk Community!

Detecting Remote Code Executions With the Splunk Threat Research Team

WATCH NOWRemote code execution (RCE) vulnerabilities pose a significant risk to organizations. If exploited, ...

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...