Getting Data In

Why are we unable to connect to Splunk Cloud from Mule?

New Member


I tried using HEC and configured log4j as mentioned below in Mule,
but I'm getting a connection timed out error.

<Http name="Splunk"
        <Property name="Authorization" value="*****token****" />
        <PatternLayout pattern="%-5p %d [%t] %X{correlationId}%c: %m%n" />

Added following dependency in pom



Log4j2-TF-7-AsyncLoggerConfig--4 ERROR Unable to send HTTP in appender [Splunk] Connection timed out: connect

Any help is appreciated.

0 Karma

Community Manager
Community Manager

Hi @mragavan ,

Did you have a chance to check out an answer? If it worked, please resolve this post by approving it! If your problem is still not solved, keep us updated so that someone else can help you.

Thanks for posting!

0 Karma

Super Champion

Hi @mragavan,

A time out usually indicates that a firewall could be blocking your connectivity.

Could you run the following see if you're able to get a connection : telnet HEC_IP 8888


0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!