Getting Data In

Why am I unable to start Splunk on AIX server after installing forwarder?

Shreyas88
New Member

I have a 64 bit AIX machine. And i installed the 64 bit splunk forwarder. But when i try to start the splunk i'm getting the error as "bash: ./splunk: cannot execute binary file" Please help me in starting splunk. Below are the version info

/apps/splunk/splunkforwarder/bin> getconf KERNEL_BITMODE
64

/apps/splunk/splunkforwarder/bin> file ./splunk
./splunk: ELF 64-bit LSB version 1 executable

0 Karma

mgaraventa_splu
Splunk Employee
Splunk Employee

Possibly you are using the wrong binary for your OS. Could you please try with ./splunk start --debug ? If you should get the same error, please try with file ./splunkand this should clarify the exact nature of your splunk binary.

Please refer also to this answers post: http://answers.splunk.com/answers/101245/cannot-execute-binary-file-linux-virtual-machine.html

Shreyas88
New Member

I'm using AIX 7.1.3.0

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...