Getting Data In

Why am I receiving this error: Skipping itemPath, does not match path....

Path Finder

I've recently been running into issues with Splunk not ingesting files, both on universal and heavy forwarders. The example here is a UF on a Windows server. In this example, I'm trying to ingest \\path\to\file.csv, and the error I get is:

DEBUG TailingProcessor - Skipping itemPath='E:\path\to\some\other\file.txt, does not match path='\\path\to\file.csv' :Not a directory :Not a symlink

My input looks like:

index = myindex
sourcetype = mysourcetype
initCrcLength = 512

Also, I had to turn on debug logging in log.cfg to even see these errors. Otherwise there were no errors at all.

Any ideas?


Labels (1)


Same here, the UF was working fine on a Windows server than suddenly started to not ingest the file anymore. To see the error I had to put in debug mode the universal forwarder. The strange thing is that other files are still monitored and forwarded correctly.

I have even added followSymlink=false and CHECK_METHOD=modtime without any luck

disabled=0 index=myindex sourcetype=mysourcetype crcSalt = <SOURCE>
[source::D:\path\to_*\file-*_*.csv] CHECK_METHOD=modtime


0 Karma

New Member

I have the same issue. 
Somebody know how to fix this?? 

0 Karma


Hi, I am getting the same error on a unix box.  Did you ever come to a conclusion?  The input works fine for exactly the same path on a different server.

0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...