Getting Data In
Highlighted

Why am I getting warning "deployment client explicitly disabled through config"?

Path Finder

I have tried restarting everything (forwarder, deploy settings, deployment server) to no avail. I have tested that the machine in question (windows box) can connect to the the deployment port with ncat. I have enabled it through the configuration files and the command line to no avail.

I am horribly confused and at a loss on how to troubleshoot this.


deploymentclient.conf

 [deployment-client]
 disabled = false
 clientName = my--custom--name

 [target-broker:deploymentServer]
 targeturi = myserver.com:8089

splunkd.log

08-28-2014 18:59:20.086 -0400 INFO  LMTracker - Setting feature=DeployClient state=ENABLED (featureStatus=1)
...
08-28-2014 18:59:24.095 -0400 INFO  DS_DC_Common - Initializing the PubSub system.
08-28-2014 18:59:24.095 -0400 INFO  DS_DC_Common - Initializing core facilities of PubSub system.
08-28-2014 18:59:29.929 -0400 WARN  DC:DeploymentClient - DeploymentClient explicitly disabled through config.
08-28-2014 18:59:29.929 -0400 INFO  DS_DC_Common - Deployment Client not initialized.

Edit

There is no license attached to these forwarders if that matters

Highlighted

Re: Why am I getting warning "deployment client explicitly disabled through config"?

Path Finder

Reinstalling seems to have solved the immediate issue.

Update

targetUri needs a capital U

View solution in original post

Highlighted

Re: Why am I getting warning "deployment client explicitly disabled through config"?

Path Finder

Has to way back to 6.x for some legacy systems and can confirm... no clear support for targetUrl (so no https or http).

0 Karma
Highlighted

Re: Why am I getting warning "deployment client explicitly disabled through config"?

Path Finder

Some may come across this problem, if the .conf file is not in the expected location.

For example, I created an app, that I checked in triplicate... only to figure out that, I was putting the .conf in the wrong location... so, Splunk couldn't pick it up. I received the same message as above.

To test connectivity, I also reinstalled the UF and used the GUI to see if it would, "pop," in the deployment server... SUCCESS!?!?

So, I later realized that Splunk couldn't see the file because I didn't put the .conf file in the local folder inside of the app name folder.

The file belongs here on the UF:
%SplunkHome%/etc/apps//local/<.conf file>

Not:
%SplunkHome%/etc/apps//<.conf file>

As mentioned above, I have seen varying results from different syntax. My observation is that spaces sometimes matter after the equals sign. Going directly from docs.splunk.com, it seems that there are very subtle inconsistencies in syntax. Spacing the argument from the variable seems to work most consistently for me.

Best Wishes.

0 Karma