Getting Data In
Highlighted

Universal forwarder not using updated index property in inputs.conf

Communicator

While i was working on a few transforms I pointed my forwarder to a "test" index. Once I got the transforms working the way I wanted to, I tried to point the forwarder back to my "main" index, but it doesn't seem to be picking up my change. I've restarted the Windows Universal Forwarder service a few times with no effect. Here's the inputs definition from $SPLUNK_HOME/etc/system/local/inputs.conf (on the forwarder):

[monitor://D:\LogFiles\W3SVC1]
disabled = 0
index = main
whitelist = ex(\d+).log
sourcetype = iis-2

The indexer continues to insert these events into the "test" index instead of "main". Any ideas why this is happening?

Tags (2)
Highlighted

Re: Universal forwarder not using updated index property in inputs.conf

Builder

jstockamp,

Can you verify that your indexer(s) is not affecting the target index. Any index routing props/transforms defined based on host/source/sourcetype for this data could be affecting the target index.

0 Karma
Highlighted

Re: Universal forwarder not using updated index property in inputs.conf

Communicator

I'm not setting the index with any of my transforms ... only filtering out some unwanted data.

0 Karma
Highlighted

Re: Universal forwarder not using updated index property in inputs.conf

Builder

Got it. Was not sure what transforms you were referring to. Your settings look correct.

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.