Getting Data In

Universal Forwarder not reading user-seed.conf (version 7.2.6).

plymalebl
Engager

I have read other articles but haven't found an answer.

I recently pushed the universal forwarder to Windows clients to upgrade from 6.5.1 to 7.2.6 and did not set the user password. The forwarder is functioning, but on start throws the error for "No user configured". I created a user-seed.conf using the instructions with a hashed password and pushed it from the Windows SCCM with a restart after placing the file into system local as described in the user-seed.conf.spec page.

However, the forwarder does not seem to be reading it on restart since I am still seeing the same error. Has anyone else found a reason for this?

We have checked file permissions and don't see a problem. The forwarder is running as a local system service and is seen as a local administrator for the user. The local admin has permissions to the user-seed.conf file.

0 Karma

codebuilder
SplunkTrust
SplunkTrust

If you are certain the permissions are correct on the config, the issue is likely with permissions on the parent directory.

The best way to validate is to modify the pass4SymmKey value in user-seed.conf by adding a plain text value, cycle Splunk, then examine the pass4SymmKey value in the same file. If it has become hashed after cycling Splunk, then the file is being read correctly and your password is invalid. If the value has not changed from plain text to a hashed value, then Splunk is unable to reach the config file and you should examine permissions of the file, directory, parent directory, etc.

----
An upvote would be appreciated and Accept Solution if it helps!
0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!