Getting Data In

TSTATS and searches that run strange

domino30
Path Finder

tstats and search.PNGtstats and search.PNG

 I think my question is --Is the Search overall returning the SRC filed the way it does because  either A there is no data or B filling in from the search and the search needs to be changed.

This is a tstats search from either infosec or enterprise security.

What should I change or do I need to do  something different.

Labels (4)
0 Karma

inventsekar
SplunkTrust
SplunkTrust

May i rephrase your question like this:


The tstats search runs fine, returns the SRC field, but the SRC results are not what i expected... 

because ..

A) there is no data

B) filling in from the search and the search needs to be changed

 

Can you pls copy paste the search query inside the question.. it will help us copy ur query and run it in our splunk. thanks. 

 

0 Karma

domino30
Path Finder

It came from the infosec app under host investigation

Here is the search

| tstats summariesonly=true allow_old_summaries=true max(_time) as _time, values(Authentication.action) as action, values(Authentication.app) as app, count from datamodel=Authentication.Authentication where (Authentication.src="::ffff:10.4.118.10" OR Authenication.dest="::ffff:10.4.118.10") by Authentication.src, Authentication.src_user, Authentication.dest, Authentication.user
| rename "Authentication.*" as "*"
| eval src=if((src=== "unknown"),null(),src), dest=if((dest == "unknown"),null(),dest)
| fields + _time, src, dest, action, app, count, user, src_user, count
| sort - count

0 Karma

inventsekar
SplunkTrust
SplunkTrust

thanks for the Search Query... but still your question "Is the Search overall returning the SRC filed the way it does because  either A there is no data or B filling in from the search and the search needs to be changed."

is not clear.. please update us, from the tstats command what kind of results you are looking for(maybe provide us a table format sample output what you are looking for)..then we can reverse engineer the tstats command for your.. thanks.

0 Karma

domino30
Path Finder

figured out I was searching for what I got in the example that I got however I got  another question

what about this.PNGwhat about this.PNG

 what about these unknowns and also the src is funky but I think its because if it not known it returns that ::fff10.x.x.x. field but im not sure

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

How much can you really learn in 3 minutes?

Observability can certainly be hard to understand – there's a lot of jargon and buzzwords and it seems to ...

Event Series: The Agentic SOC: Trust Before Autonomy

AI is fundamentally changing security operations, but true progress requires more than just automation—it ...

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...