Getting Data In

Splunk php sdk error fopen (https://localhost:8089/services/auth/login): failed to open stream: operation failed

New Member

Getting started with the Splunk API using php and am encountering this issue. Curl works with -k as one would expect. Login to web ui works on port 8000?

0 Karma

SplunkTrust
SplunkTrust

fopen is usually FILE open, and I only use it when reading/writing to file system.??? I'm no Python pro... So it appears that you may be using the sdk incorrectly. Can you please show your code?

0 Karma

SplunkTrust
SplunkTrust
0 Karma

New Member

Hello jkat54,

I'm using the index.php from the php sdk examples. Just following the docs at this point. I have copied settings.default.php to settings.local.php as is described using my login credentials.

Thanks for looking at this.

0 Karma

SplunkTrust
SplunkTrust

Are you using the latest version of splunk enterprise 6.3.2?

0 Karma

New Member

Using 6.3.3

looking at splunkd.log this might be a ssl/tls error

02-10-2016 18:11:42.796 -0700 WARN HttpListener - Socket error from 127.0.0.1 while idling: error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca

0 Karma

New Member

index.php

<h4 class="alert-heading">Examples Unconfigured.</h4>
You are using the default name and password. Please copy the
<strong>settings.default.php</strong> file in this directory to
<strong>settings.local.php</strong> and edit it appropriately.





<h4 class="alert-heading">Login Failed.</h4>
Reason: <code><?php echo htmlspecialchars($loginFailReason); ?></code>

Examples

settings.local.php

0 Karma

SplunkTrust
SplunkTrust

Are you doing this on a web server with php installed etc? Or just opening the example in a browser?

0 Karma

New Member

This is on a locally installed web server. apache2. Running out of a user directory for simplicity at this moment.

Thanks.

0 Karma

SplunkTrust
SplunkTrust

Cool I'll give it a shot in the same configuration after I kick this stomach bug...

0 Karma

SplunkTrust
SplunkTrust

Login to the web UI defaults to 8000, the REST API defaults to 8089.

0 Karma

New Member

Understood. Using 8089 for default rest api. Just stating that there is functionality of the system.

Error in title shows port 8089 is being used.

Thanks Martin for looking at this.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!