Getting Data In

Splunk OTEL Collector: Log Scarping Issue

vprasadeee_7
Explorer

Dear Team,

We have configured the Splunk OTEL collector to collect logs from OpenShift environment namespaces and Pods and send them to Splunk Enterprise using HEC (HTTP Event Collector). However, we are experiencing unusual behavior with the values.yaml configuration when it comes to collecting audit logs.

logsCollection:
extraFileLogs:
filelog/audit-log-kube-apiserver:
include: [/var/log/kube-apiserver/audit.log]
start_at: beginning
include_file_path: true
include_file_name: false
resource:
com.splunk.source: /var/log/kube-apiserver/audit.log
host.name: 'EXPR(env("K8S_NODE_NAME"))'
com.splunk.sourcetype: kube:apiserver-audit

I'm having an issue with the OTEL collector Pod. Whenever I restart it, it starts ingesting data from the beginning instead of resuming where it left off. I've tried modifying the "start_at" option by setting it to "current," but that didn't work. I also attempted removing the key-value pair, but it didn't solve the problem. I would greatly appreciate any assistance in resolving this matter.

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Extending Observability Content to Splunk Cloud

Watch Now!   In this Extending Observability Content to Splunk Cloud Tech Talk, you'll see how to leverage ...

More Control Over Your Monitoring Costs with Archived Metrics!

What if there was a way you could keep all the metrics data you need while saving on storage costs?This is now ...

New in Observability Cloud - Explicit Bucket Histograms

Splunk introduces native support for histograms as a metric data type within Observability Cloud with Explicit ...