Getting Data In

Running splunk diag gets stuck at "Getting index listings..."

andrei_radu
New Member

Hi,

I am trying to create a diag file on one of my indexers and the process is stuck at "Getting index listings..." for more than 1 hour.

Has anyone came across something similar and have a suggestion how to troubleshoot?

Regards!

Tags (2)
0 Karma
1 Solution

dineshraj9
Builder

Sometimes diag files can really consume a lot of space. You can filter out some of the contents like this -

./splunk diag --exclude */.snapshot/* --exclude */dispatch/* --exclude */search_pool/etc/users/* --exclude *.tgz* --exclude *.tar* --exclude *.gz* --exclude *.zip* --exclude *.png --exclude *.jpg --exclude *.jpeg --exclude *.gif --exclude *.so* --exclude *.old.* --exclude *.csv.* --exclude *.bundle*

View solution in original post

dineshraj9
Builder

Sometimes diag files can really consume a lot of space. You can filter out some of the contents like this -

./splunk diag --exclude */.snapshot/* --exclude */dispatch/* --exclude */search_pool/etc/users/* --exclude *.tgz* --exclude *.tar* --exclude *.gz* --exclude *.zip* --exclude *.png --exclude *.jpg --exclude *.jpeg --exclude *.gif --exclude *.so* --exclude *.old.* --exclude *.csv.* --exclude *.bundle*

View solution in original post

andrei_radu
New Member

Thanks, excluding some parts of the diag file worked.

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!