Getting Data In

Recursive query based upon current result set

catsmeowor
Explorer

Having some trouble figuring this out, and fishing for an example as well.

Have an index that contains URL traffic logs. The category of these logs is dynamically updated each day.

index=url_logs category=malware | table user category url --> i get my results if there's any hits

But i what I'd like to do is to search for anything that currently matches malware on today's date with a search going back at least a week. That way I could tell if there was a lot of allowed traffic to a site that is now malicious and investigate from there.

Any suggestions? Thank you!

Tags (1)
0 Karma

valiquet
Contributor

index=url_logs url=* | stats values(user), values(url) by category | where category=malware

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...