Getting Data In

Problems creating an UDP input: Error binding to socket in UDPInputProcessor: Permission Denied

psobisch
Path Finder

Hello,

After a new installation of universal forwarder 6.1.2 on a new RHEL6 machine we have just copied the appropriate app directory to the new forwarder (a procedure which was working every time in the past) but now, we've got a problem because the input which was configured in the app (udp://514), was not created.

Inside of splunkd.log I found:

Error binding to socket in UDPInputProcessor: Permission Denied

Splunk is running as splunk:splunk.

What went wrong?
Do you have any hints?

Regards,
Peter

Tags (2)
0 Karma

martin_mueller
SplunkTrust
SplunkTrust

Non-root users cannot bind to ports below 1024 on Linux systems.

You could forward 514 to e.g. 5140 and have Splunk listen on that (talk to your Linux admins), or have your sources send data on a different port, or - probably best - have a syslog daemon receive the data on 514, write it to log files, and let the forwarder read those.

psobisch
Path Finder

thanks! Just forgotten it! 🙂
I was confused because we have an older instance of forwarder running with the same app, but, in fact splunk was running as root.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...