Getting Data In

On the VMware App, following upgrade from v3.2.x to v3.3.1, data volume is ~10x higher

bohanlon_splunk
Splunk Employee
Splunk Employee

Situation = On the VMware App, following upgrade from v3.2.x to v3.3.1.
Unexpected desired behaviour = Data volume is ~10x higher (than is was on v3.2.x )

Tags (1)
1 Solution

bohanlon_splunk
Splunk Employee
Splunk Employee

What happened?
This is an occurrence of bug VMW-4431.

Why did this happen?
A change was made to the VMware-TA to enable instance level data collection.
BEFORE ITSI support in TA, it was collecting aggregated data for CPU, Datastore, Nic etc.
AFTER enabling instance level data collection, it will get event per CPU core, per Datastore, per nic.
For example, if VM has 12vCPU assigned, we would collect 12 events instead of a single aggregated event like before.

How can I get around this?
Below is a specific configuration which could be tweaked to enable/disable instance level data in /$SPLUNK_HOME/etc/apps/Splunk_TA_vmware/default/ta_vmware_collection.conf
The following lines should be commented out if you DO NOT want to collect instance level data:
host_instance_whitelist = .*
vm_instance_whitelist = .*

View solution in original post

bohanlon_splunk
Splunk Employee
Splunk Employee

What happened?
This is an occurrence of bug VMW-4431.

Why did this happen?
A change was made to the VMware-TA to enable instance level data collection.
BEFORE ITSI support in TA, it was collecting aggregated data for CPU, Datastore, Nic etc.
AFTER enabling instance level data collection, it will get event per CPU core, per Datastore, per nic.
For example, if VM has 12vCPU assigned, we would collect 12 events instead of a single aggregated event like before.

How can I get around this?
Below is a specific configuration which could be tweaked to enable/disable instance level data in /$SPLUNK_HOME/etc/apps/Splunk_TA_vmware/default/ta_vmware_collection.conf
The following lines should be commented out if you DO NOT want to collect instance level data:
host_instance_whitelist = .*
vm_instance_whitelist = .*

View solution in original post

.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!