Getting Data In

Not able to add monitor a directory. I'm getting Parameters must be in the form '-parameter value' error.

druvakumar
Path Finder

I tried two ways
1). C:\Program Files\SplunkUniversalForwarder\bin>splunk add monitor -source C:\Program Files\Atlassian\Application Data\JIRA\log
Parameters must be in the form '-parameter value'

2). C:\Program Files\SplunkUniversalForwarder\bin>splunk add monitor -source C:\Program Files\Atlassian\Application Data\JIRA\log\atlassian-jira.log
Parameters must be in the form '-parameter value'

I'm getting I'm getting Parameters must be in the form '-parameter value' error. Can someone help me here?

Labels (1)
0 Karma
1 Solution

p_gurav
Champion

Can you try:

C:\Program Files\SplunkUniversalForwarder\bin>splunk add monitor C:\Program Files\Atlassian\Application Data\JIRA\log

Also try using tab for auto selecting source name including space.

View solution in original post

0 Karma

p_gurav
Champion

Can you try:

C:\Program Files\SplunkUniversalForwarder\bin>splunk add monitor C:\Program Files\Atlassian\Application Data\JIRA\log

Also try using tab for auto selecting source name including space.

0 Karma

druvakumar
Path Finder

I tried "C:\Program Files\SplunkUniversalForwarder\bin>splunk add monitor C:\Program Files\Atlassian\Application Data\JIRA\log" this aswell, it didn't work
is there any other param which we need to include?

0 Karma

p_gurav
Champion

Can you try putting source in double quotes:

C:\Program Files\SplunkUniversalForwarder\bin>splunk add monitor "C:\Program Files\Atlassian\Application Data\JIRA\log"

druvakumar
Path Finder

Thank you! it worked 🙂

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Splunk is probably not liking the space in the source file name. Try putting double quotes around the name or use the 8.3 form of file name (C:\Progra~1\...).

---
If this reply helps you, Karma would be appreciated.

vishwanthini
Engager

By using double quotes around the path worked for me. Until i put it in double quotes, i kept getting the "Parameters must be in the form '-parameter value'" error

Here is the command i used
C:\Program Files\SplunkUniversalForwarder\bin>splunk install app "C:\Program Files\Splunk\splunkclouduf.spl" -auth admin:changeme

0 Karma
Get Updates on the Splunk Community!

Sending Metrics to Splunk Enterprise With the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

What's New in Splunk Cloud Platform 9.0.2208?!

Howdy!  We are happy to share the newest updates in Splunk Cloud Platform 9.0.2208! Analysts can benefit ...

Want a chance to win $500 to the Splunk shop? Take our IT Incident Management Survey!

  Top Trends & Best Practices in Incident ManagementSplunk is partnering up with Constellation Research to ...