Getting Data In

Network Monitoring between Enterprise Security Search Head and Indexers

shedalkar
Engager

Is it possible set up a monitoring of the data transfer rates between search head and indexer.
We are especially interested in the amount of data transferred for the scheduled searches that Enterprise Security runs every day. The transferred data per hour, ideally in form of a chart and a total value per day.

Thanks.

0 Karma

adonio
Ultra Champion

hello there,
you can use the eval len function on data from the particular search head you are after.
here is the code:

    index = _internal OR index = _audit host = <YourSearchHeadHere>
    | eval total_bytes = len(_raw)
    | eval bytes_kb = round(total_bytes/1024, 2)
    | eval bytes_mb = round(total_bytes/1024/1024, 2)
    | eval bytes_gb = round(total_bytes/1024/1024/1024, 2)
    | stats sum(bytes_*) as total_internal_audit_*  by host

here is a screenshot:
alt text

0 Karma

adonio
Ultra Champion

do you mean the amount of internal data that goes to _audit, _internal indexes?

0 Karma

shedalkar
Engager

yes. So is it possible to monitor this ? If yes, can you please let us know how ?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...