Getting Data In

Nested Loop or a Sub-search

amanno
New Member

Hi guys,

I know there has to be a straightforward way to do this in SPL just can't figure out which to use.

I have a data set like so (CSV format):

Trial Id, Size, Result, Value
1, 64, Passed, 15000
1, 64, Passed, 14957
1, 64, Failed, 15230
1, 258, Passed, 7000
1, 258, Failed, 7500
1, 258, Passed, 6950
1, 315, Failed, 2300
1, 315, Failed, 2200
1, 315, Passed, 2100

2, 64, Passed, 15095
2, 64, Passed, 14777
2, 64, Failed, 15690
2, 258, Passed, 7100
2, 258, Failed, 7250
2, 258, Passed, 6350
2, 315, Failed, 2200
2, 315, Failed, 2000
2, 315, Passed, 2195

3, 64, Passed, 15020
3, 64, Passed, 14990
3, 64, Failed, 15245
3, 258, Passed, 7012
3, 258, Failed, 7504
3, 258, Passed, 6951
3, 315, Failed, 2309
3, 315, Failed, 2211
3, 315, Passed, 2199

And I need to compute the average of all max values per size per Trial ID (for only the ones that have Result=Passed)

This is what I have so far:

index="main" Result=Passed Size=64 | stats max(Value) as max_value by "Trial Id" | stats avg(max_value) 

Which does give me the value I am looking for but only for the "Size=64" case. How do I iterate over all the different sizes, while computing the "avg(max_value)" for each of the different sizes? I then plan to chart the average max size over the "size".

Thanks for any help!

0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi amanno,
did you tried to insert also Size in stats clauses?

index="main" Result=Passed | stats max(Value) as max_value by "Trial Id" Size | stats avg(max_value)  By Size

Bye.
Giuseppe

View solution in original post

gcusello
SplunkTrust
SplunkTrust

Hi amanno,
did you tried to insert also Size in stats clauses?

index="main" Result=Passed | stats max(Value) as max_value by "Trial Id" Size | stats avg(max_value)  By Size

Bye.
Giuseppe

amanno
New Member

Thank you so much Giuseppe! That is exactly what I was looking for...knew it had to be something simple. Thanks again!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...