Getting Data In

Need to pull logs month wise

rakesh43
New Member

Hi , I have 13 months of data , need to pull data month wise & year wise

24/10/2018
14:43:50.556

2018-10-24 14:43:50.556, S_DATE="20160208", SCENARIO="Actual", YEAR="2016", PERIOD="Feb", VIEW="YTD", ENTITY="1009", ENTITY_DESC="Test Canada Inc.", MARKET="Canada", ACCOUNT="922002", ACCOUNT_DESC="922002 - Employee Activity Food And Beverages", INTER_ENTITY="[ICP None]", VALUE="[Parent Total]", RC="216102", SUBACCOUNT="000000", INTER_RC="000000", PRODUCT="000000", CUSTOM5="USD_FUNC_Total", DATA_TYPE="Total_Late", DDATA="179.03916480009201"

host = Test

source = test_hist

sourcetype = test_hist

Tags (1)
0 Karma

rakesh43
New Member

Dec 2017 to Dec 2018 date

0 Karma

rakesh43
New Member

index=test sourcetype=test_hist YEAR = "2017" PERIOD = "Dec" ACCOUNT = 949005 RC = 301873
| eval CC= RC."-".ACCOUNT."-".SUBACCOUNT."-". INTER_ENTITY."-".INTER_RC."-".PRODUCT."-00-0000" , DATE = YEAR."-".PERIOD
| table CC, DATE, YEAR, PERIOD, ENTITY, ACCOUNT, ACCOUNT_DESC, RC, SUBACCOUNT, INTER_RC, PRODUCT, DDATA '

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...