Getting Data In

Need help with splunk SPL or REST API

AK_Splunk
Explorer

Need help with splunk SPL or rest api to fetch areport where we can see the count of total servers(splunk universal forwarders) reporting to IDX and HF with breakup.

Some UF are sending data to IDXers directly and few of them are sending it via HF(due to some connection issues we have followed this architecture)

Please assist me on the same.

Labels (1)
0 Karma

SanjayReddy
SplunkTrust
SplunkTrust

Hi @AK_Splunk 

can you run  query1 or query2 search in search head , hope one of helps your requriment 

Query1

index=_internal source="*metrics.log" group="tcpin_connections"
| dedup hostname
| rename host as "receiver host" hostname as "sender host"
| table _time "sender host" connectionType version sourceIp destPort ssl fwdType "receiver host" 


Query2

index=_internal source="*metrics.log" host IN (UF1,UF2) 
group=tcpout_connections
| stats count by host destIp destPort

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...