Getting Data In

Line breaking stops working from 12am - 1am everyday

king2jd
Path Finder

Hello,

We have a distributed environment with load balancing to 9 indexers. At 12am, our logs stop line breaking and start group multiple entries into one event and random log lines (no timestamps) for the next hour. Then it miraculously starts to work again. Never seen such a thing, thoughts?

alt text

0 Karma

woodcock
Esteemed Legend

The problem is that your timestamp is using <date><SingleSpace><SINGLE digit hour=0> for the midnight hour but it is using <DATE><SingleSpace><DOUBLE digit hour> the rest of the time. So you need to make sure that your TIME_FORMAT, MAX_TIMESTAMP_LOOKAHEAD, LINE_BREAKER, etc. can each accommodate this variability. One of these is poorly-written enough to fail on the zero-hour because that format is different than all of the others.

burwell
SplunkTrust
SplunkTrust

Could this be an error in regex on the line breaking?

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet Splunk Observability Studio: AI-Assisted OpenTelemetry Instrumentation Without ...

Instrumentation is usually the last step or even an afterthought when building out a project. The feature ...

Federated Search for Cisco Security and Analytics Logging (SAL) is now GA on Splunk ...

Federated Search for Cisco  Security Analytics and Logging (SAL) is now generally available as part of the ...

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner   Join us for a demo-driven look at how ...