Getting Data In

Indexer cluster: "Oldest Data Age" extremely high for some indexes

Path Finder


We have noticed that in Monitoring Console-> Indexing-> Indexes and Volumes -> Indexes and Volumes: Deployment Dashboard, the "Oldest Data Age (days)" value for a few indexes is extremely high (e.g. 1959 days). Retention time for those indexes is 180 days (frozenTimePeriodInSecs = 15552000).
We have checked the data and it really shows very old events (e.g. from 2017) although ignoreOlderthan = 14d parameter has been added to inputs.conf during data onboarding.

We have already deleted the very old data (older than 400 days) with a "delete" command, but the Indexes and Volumes: Deployment Dashboard keeps showing very old values for the

Anyone knows what else to check and how to solve this issue?


Labels (7)
0 Karma


The ignoreOlderThan setting has no bearing on data retention. It only controls what input files Splunk reads.

The delete command does not remove data from indexes. It merely hides the events.

Data is deleted by bucket and doesn't happen until the newest event in a bucket is at least 6 months old. The dbinspect command can show the newest and oldest event dates for each bucket.

    Many sites avoid this problem by setting a maximum lifetime of 24 hours for a hot bucket. ( maxHotSpanSecs = 86400 in indexes.conf).
If this reply helps you, Karma would be appreciated.
Get Updates on the Splunk Community!

Streamline Data Ingestion With Deployment Server Essentials

REGISTER NOW!Every day the list of sources Admins are responsible for gets bigger and bigger, often making the ...

Remediate Threats Faster and Simplify Investigations With Splunk Enterprise Security ...

REGISTER NOW!Join us for a Tech Talk around our latest release of Splunk Enterprise Security 7.2! We’ll walk ...

Introduction to Splunk AI

WATCH NOWHow are you using AI in Splunk? Whether you see AI as a threat or opportunity, AI is here to stay. ...