Getting Data In

I have been trying to pass a CLI command remote to my forwarder and get no response?

rsimmons
Splunk Employee
Splunk Employee

After I upgraded from 4.1.4 to 4.1.5, I can not pass commands via the CLI to the running instance.

Tags (1)
0 Karma

sgtquezada
New Member

We are using bladelogic to execute the list forward-server command remotely to verify the configs are correct after install. BL is using NSH or psexec. However, since the upgrade to 4.1.5 - we are getting an error and won't allow us to run the command.

We've changed the default password and added the allowRemoteLogin = always to the server.conf on the light forwarder. Has anyone else experienced this issue?

0 Karma

rsimmons
Splunk Employee
Splunk Employee

Starting in 4.1.4, remote CLI access is disabled by default for the admin user until you have changed its default password.

To enable the remote access you will have to set the following stanza:

$SPLUNK_HOME/etc/system/local/server.conf and set the value:

allowRemoteLogin=always

gkanapathy
Splunk Employee
Splunk Employee

Or change the password from the default.

0 Karma
Get Updates on the Splunk Community!

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...

Edge Processor Scaling, Energy & Manufacturing Use Cases, and More New Articles on ...

Splunk Lantern is a Splunk customer success center that provides advice from Splunk experts on valuable data ...

Get More Out of Your Security Practice With a SIEM

Get More Out of Your Security Practice With a SIEMWednesday, July 31, 2024  |  11AM PT / 2PM ETREGISTER ...