Getting Data In
Highlighted

How to disable splunk-regmon.exe?

Explorer

The process splunk-regmon.exe is running 95%-99% CPU (Splunk 3.1.4, WinXP SP3 as a VM in VMware Fusion 3.1.1). How do I disable this process? It is not showing in Services, though Splunkd and SplunkWeb are. If I disable it will it cause a problem with Splunk running on this machine?

Tags (2)
0 Karma
Highlighted

Re: How to disable splunk-regmon.exe?

Splunk Employee
Splunk Employee

I'll assume you mean 3.4.1, because I don't think there was a Splunk 3.1.4 on Windows. It is probably enabled in c:\program files\splunk\etc\system\local\inputs.conf, with a stanza like:

[script://$SPLUNK_HOME\bin\scripts\splunk-regmon.py]
disabled = 0

If you change it to disabled = 1, and restart, that should stop it. You will of course lose the ability to collect registry data if it's not running. You may be able to reduce its footprint and still leave it running by editing regmon-filters.conf.

In later versions of Splunk (and possibly in yours, I'm not sure), the file might be in c:\program files\splunk\etc\apps\windows\local instead.

Highlighted

Re: How to disable splunk-regmon.exe?

Explorer

Oops, I meant 3.4.13. Your fix worked. I found it in the first location (not the second) and after disabling the process and restarting I no longer have CPU activity spiking.

And of course now I'm curious as to why this happened at all. It was coincident with upgrading VMware Fusion from 3.1.0 to 3.1.1. That is, the process took off after the upgrade/restart cycle completed.

0 Karma