Getting Data In
Highlighted

How to Configure host = $decideOnStartup correctly?

Explorer

I have application with inputs.conf as
[monitor:xxxxx]
sourcetype=xxxx
index=xxxx
host = $decideOnStartup

In serverclass.conf i have entry like
[serverClass:all_clients:app:]
restartSplunkWeb = 0
restartSplunkd = 1
stateOnClient = enabled

Now when i reload deployment server, I can see my deployment app pushing successfully on boxes. But $decideOnStartup is not working as expected untill i manually restart splunk on the forwarder node.
even though splunkd gets restarted after app gets pushed to forwarder. I have to manually restart splunk on forwarder box again.
Am i missing any configuration?

Highlighted

Re: How to Configure host = $decideOnStartup correctly?

Contributor

Your conifg looks correct.

We use the same config, but never NOTICED it did work.
What version are you running?

0 Karma
Highlighted

Re: How to Configure host = $decideOnStartup correctly?

New Member

Not sure if you fixed this. But did you check if there is an inputs.conf under $SPLUNK_HOME/etc/system/local? This will override the inputs.conf settings under your custom application.

0 Karma