Getting Data In

How to Blacklist a hostname in inputs.conf?

Path Finder

Hi Team,

In our environment, We have all apps in our deployment server and from there we used to deploy it so that it will reach all our indexers.

Currently, we have an app in our deployment server and in that we have inputs.conf (/opt/splunk/etc/deployment-apps/appname/local/inputs.conf) and in that we want to blacklist a server in inputs.conf

This is the sample like Inputs.conf file:

[monitor:///xx/xx/Xxx/xxxx/xxxx.*]
sourcetype = xxxxxx
blacklist = (servername)
index = xxxx
disabled = 0

So in this stanza I have mentioned the servername under blacklist= (servername) but still the logs are getting ingested into Splunk for those index and sourcetype. So how to blacklist the server in inputs.conf

So kindly let me know how to fix the same.

0 Karma

Motivator

Hi @anandhalagarasan:

Create separate app for this input and dont deploy it to that server (as mentioned by @teunlaan)

0 Karma

Contributor

you should blacklist it in your serverclass, so you don't deploy it too the server.

0 Karma