Getting Data In

How can I achieve the query for retrieving data for a particular time for the last 6 days?

Subarna
Explorer

How can I achieve the query for retrieving data for a particular time for the last 6 days? Suppose I want to get the data for last 6 days from time 12.00 A.M to 4.00 P.M. Please help on the same

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Subarna,

you have to run a search for the full period adding a filter on the hosu, something like this:

index=your_index earliest=-6d@d latest=@d (date_hour>11 date_hour<17)
| ...

if you haven't date _hour, you have to extract it:

index=your_index earliest=-6d@d latest=@d 
| eval date_hour=strftime(_time,"%H")
| where date_hour>11 AND date_hour<17
| ...

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...