Getting Data In

Having trouble cleaning index data

xcalibur
New Member

[root@syslog bin]# ./splunk clean eventdata
In order to clean, Splunkd must not be running.

Attempting to run splunkd fails with a libssl library not existing.
Wasnt able to locate that one anywhere...

I'm running CENTOS 6.4
Please HELP!

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

The warning about libssl is almost certainly because you are trying to run splunkd directly, instead of splunk.

0 Karma

Ayn
Legend

It's exactly like the error message says - you can't clean your index while Splunk is running. Run "splunk stop" (NOT "splunkd stop", splunkd is not meant to be run directly by users), then clean out your index(es).

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...