Getting Data In

Getting Rest endpoint errors when pushing the Splunk_TA_ontap app to all the indexers through Master.

Explorer

When pushing the SplunkTAontap app of "Splunk app for NetApp Data ONTAP" to all the indexers in the cluster through Master it gets added to etc/slave-apps folder and gives the below errors for all indexers in cluster on Search Head -> NetApp Data ONTAP app -> Settings -> ONTAP Collection Configuration dashboard:-

Failed to fetch REST endpoint uri=https://127.0.0.1:8089/servicesNS/nobody/Splunk_TA_ontap/data/inputs/ta_ontap_collection_scheduler/n... from server=https://127.0.0.1:8089

Unexpected status for to fetch REST endpoint uri=https://127.0.0.1:8089/servicesNS/nobody/Splunk_TA_ontap/data/inputs/ta_ontap_collection_scheduler/n... from server=https://127.0.0.1:8089 - Not Found

When checked on the indexer node the "taontapcollectionscheduler" Rest Endpoint was not getting created if the "SplunkTA_ontap" app is in the etc/slave-apps folder.

If we move the "SplunkTAontap" folder from the etc/slave-apps folder to ect/apps folder on an indexer, the "taontapcollection_scheduler" Rest Endpoint gets created on the indexer and it stops giving the above errors for that indexer.

Any Suggestions!

Communicator

Ensure the Search head is Linux and the Data Collection Node has at least 1 Worker Process enabled in the Ontap Collection Configuration

0 Karma

Path Finder

specify argument splunk_server="local" or your "indexer url" to your rest call.

Explorer

Hi sgundeti,
Do you know what file/s we would add this too in the NetApp splunk app?
Thanks!
--Jason

0 Karma

Path Finder

Look for searches using rest command(probably in ONTAP Collection Configuration dashboard) and try to add splunk_server value=local or "your indexer servername"

0 Karma

Path Finder

I am having this problem with the Splunk app for NetApp Data ONTAP, too.

0 Karma

Explorer

I'm getting the same problem as well.

0 Karma