Getting Data In
Highlighted

Error trying to add csv

New Member

I'm trying to upload a csv file via the Upload button and when I do I get the following error "'module' object has no attribute 'makeSplunkdUri'". I've tried on several different csv files and all the same error. On version 6.2.0. Any ideas?

alt text

0 Karma
Highlighted

Re: Error trying to add csv

Builder

Sounds like you might have a permissions issue or some missing files on your Splunk box.

Check here and see if your files are complete.
https://docs.splunk.com/Documentation/Splunk/7.0.1/Admin/ChecktheintegrityofyourSplunksoftwarefiles

If not, the solution is to fix pemissions (examples --Right click in windows or sudo chown -R splunk:splunk /opt/splunk/)

And then reinstall (or upgrade to 7.0.1)

On a side note.. For kicking files into my test stand-alone 500mb splunk I just setup a folder on my workstation called dump, and then added this to my local splunk forwarder inputs.conf file. Then on my Windows workstation I can just drag files into c:\dump and the forwarder just grabs it for me.

[monitor://C:\dump\*]
disabled = 0
recurse=true
followTail = 0
sourcetype=dump
ignoreOlderThan = 10d
index = main
0 Karma