Getting Data In

EPO version 5.10 cannot connect with Db Connect version 3.1.3

Bubbagump2018
Observer
Within connections I can only select driver MS-SQL server using MS generic driver.
I am getting error com.microsoft.sqlserver.jdbc.SQLServerException: The value is not set for the parameter number 1
I think it is a driver issue but cannot select another driver

Does anyone have an idea how to fix this


SELECT

        [EPOEvents].[ReceivedUTC] as [timestamp],

        [EPOEvents].[AutoID],

        [EPOEvents].[ThreatName] as [signature],

        [EPOEvents].[ThreatType] as [threat_type],

        [EPOEvents].[ThreatEventID] as [signature_id],

        [EPOEvents].[ThreatCategory] as [category],

        [EPOEvents].[ThreatSeverity] as [severity_id],

        [EPOEventFilterDesc].[Name] as [event_description],

        [EPOEvents].[DetectedUTC] as [detected_timestamp],

        [EPOEvents].[TargetFileName] as [file_name],

        [EPOEvents].[AnalyzerDetectionMethod] as [detection_method],

        [EPOEvents].[ThreatActionTaken] as [vendor_action],

        CAST([EPOEvents].[ThreatHandled] as int) as [threat_handled],

        [EPOEvents].[TargetUserName] as [logon_user],

        [EPOComputerProperties].[UserName] as [user],

        [EPOComputerProperties].[DomainName] as [dest_nt_domain],

        [EPOEvents].[TargetHostName] as [dest_dns],

        [EPOEvents].[TargetHostName] as [dest_nt_host],

        [EPOComputerProperties].[IPHostName] as [fqdn],

        [dest_ip] = ( convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOComputerProperties].[IPV4x] + 2147483648))),1,1)))+'.'+convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOComputerProperties].[IPV4x] + 2147483648))),2,1)))+'.'+convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOComputerProperties].[IPV4x] + 2147483648))),3,1)))+'.'+convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOComputerProperties].[IPV4x] + 2147483648))),4,1))) ),

        [EPOComputerProperties].[SubnetMask] as [dest_netmask],

        [EPOComputerProperties].[NetAddress] as [dest_mac],

        [EPOComputerProperties].[OSType] as [os],

        [EPOComputerProperties].[OSCsdVersion] as [sp],

        [EPOComputerProperties].[OSVersion] as [os_version],

        [EPOComputerProperties].[OSBuildNum] as [os_build],

        [EPOComputerProperties].[TimeZone] as [timezone],

        [EPOEvents].[SourceHostName] as [src_dns],

        [src_ip] = ( convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOEvents].[SourceIPV4] + 2147483648))),1,1)))+'.'+convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOEvents].[SourceIPV4] + 2147483648))),2,1)))+'.'+convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOEvents].[SourceIPV4] + 2147483648))),3,1)))+'.'+convert(varchar(3),convert(tinyint,substring(convert(varbinary(4),convert(bigint,([EPOEvents].[SourceIPV4] + 2147483648))),4,1))) ),

        [EPOEvents].[SourceMAC] as [src_mac],

        [EPOEvents].[SourceProcessName] as [process],

        [EPOEvents].[SourceURL] as [url],

        [EPOEvents].[SourceUserName] as [source_logon_user],

        [EPOComputerProperties].[IsPortable] as [is_laptop],

        [EPOEvents].[AnalyzerName] as [product],

        [EPOEvents].[AnalyzerVersion] as [product_version],

        [EPOEvents].[AnalyzerEngineVersion] as [engine_version],

        [EPOEvents].[AnalyzerDATVersion] as [dat_version],

        [EPOProdPropsView_VIRUSCAN].[datver] as [vse_dat_version],

        [EPOProdPropsView_VIRUSCAN].[enginever64] as [vse_engine64_version],

        [EPOProdPropsView_VIRUSCAN].[enginever] as [vse_engine_version],

        [EPOProdPropsView_VIRUSCAN].[hotfix] as [vse_hotfix],

        [EPOProdPropsView_VIRUSCAN].[productversion] as [vse_product_version],

        [EPOProdPropsView_VIRUSCAN].[servicepack] as [vse_sp]

FROM [EPOEvents]

LEFT JOIN [EPOLeafNodeMT] ON [EPOEvents].[AgentGUID] =  [EPOLeafNodeMT].[AgentGUID]

LEFT JOIN [EPOProdPropsView_VIRUSCAN] ON [EPOLeafNodeMT].[AutoID] = [EPOProdPropsView_VIRUSCAN].[LeafNodeID]

LEFT JOIN [EPOComputerProperties] ON [EPOLeafNodeMT].[AutoID] = [EPOComputerProperties].[ParentID]

LEFT JOIN [EPOEventFilterDesc] ON [EPOEvents].[ThreatEventID] = [EPOEventFilterDesc].[EventId]

AND ([EPOEventFilterDesc].[Language]='0409')

WHERE [EPOEvents].[AutoID] > ?

ORDER BY [EPOEvents].[AutoID] ASC

 

 
Labels (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI + Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...