Getting Data In

Data Inputs REST / HTTP Header Properties: How can I specify a value with an "aring" (å) character in it?

Path Finder

Hi all,

So I am trying to specify a rest data input and I think there is a problem specifying a Header property which has a value with an "aring" (å) in it. I edited it into inputs.conf, but it was converted to an "a" when I saved the configuration back from Splunk Web.

I had same problem with curl as well; I got it to work by adding the property to a file which was read by means of the -K switch.
And it had to be an ANSI encoded file.

I have the following configuration which should be ok I think:

auth_password = 
auth_type = none
auth_user = 
backoff_time = 30
endpoint = https://aServer.a.dom.ain:8443/aProgram/system?_action=test
host = idm
http_method = POST
index = idm
index_error_response_codes = 1
polling_interval = 22
response_type = json
sequential_mode = 0
sourcetype = json_no_timestamp
streaming_request = 0
http_header_propertys = X-Username=aUserName,X-Password=N_XyZåAbC
disabled = 0

Does anybody know a way to input this password (seemingly ANSI-encoded) with the awkward å (aring)?

Unfortunately, changing the password is not an option.

Thanks and regards,
Bård Tørustad

0 Karma


Did you find a solution, Bard?

0 Karma


Yeah what he said... Try \xc3a5 or 0xc3a5 in place of the aring. If that doesn't work, try this urlencoding of it %C3%A5

0 Karma


There is a UTF8 encoding for aring (0x'c3a5') , which is different from the UTF16 encoding (0x'00E5')

Have you tried turning the whole thing into a hex UTF8 character string? That would look something like this

UTF8   0x004E005F00580079005AC3A5004100620043
UTF16  0x004E005F00580079005A00E5004100620043
0 Karma


I just posted a drilldown question to make sure the code sample has been vetted for format -

Posted here -

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!