Getting Data In

DBConnect 3.2 error Error while saving schema to file:

Path Finder

Hi all,

When I was trying to setup a new connection in DBConnect 3.2, i got this error message

java.sql.SQLException: Error while saving schema to file:

 anyone knows how to fix it?


Labels (1)
Tags (1)
0 Karma

New Member

Hi @Cbr1sg 


I have the same problem. Did you resolve this?

I tried to search on google but no luck 😞

It saves schema in somewhere that not has permission, I can't figure out where it saves schema.


Does anyone else have ideas about this issue?



0 Karma

New Member


After asking Unity about this error, they told me I had to add the following parameter on the JDBC URL, as well as adding the authSource

- Windows: c:/temp/mongo.xml

- Linux: /tmp/mong.xml

This is a location on where to save the schema as a XML file. You can change it to whatever you want as well as the name of the file.

They also told me that problem was that the default location for the file was not writeable, although they didn't tell me where was that location.

This is an example that worked for me:






0 Karma