Getting Data In

Can I use a REST API command to identify saved searches using a summary index?

philip_wong
Communicator

Can use a REST API command to identify saved searches using a summary index?

0 Karma
1 Solution

MuS
SplunkTrust
SplunkTrust

Hi philip.wong,

sure, try this:

| rest /services/saved/searches | search action.summary_index="1" | table title action.summary_index action.summary_index._name

Hope this helps ...

cheers, MuS

View solution in original post

MuS
SplunkTrust
SplunkTrust

Hi philip.wong,

sure, try this:

| rest /services/saved/searches | search action.summary_index="1" | table title action.summary_index action.summary_index._name

Hope this helps ...

cheers, MuS

philip_wong
Communicator

Thanks!

I don't know why | rest /services/saved/searches only returns few saved searches for me.

Finally, I use this to get what I want.

| rest /servicesNS/admin/-/saved/searches
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...