Getting Data In

Broken Pipe issues when adding new data source to Splunk from GUI

dshakespeare_sp
Splunk Employee
Splunk Employee

Customer reports that when trying to upload a local file to Splunk (Add Data -> From files and directories -> Upload and index a file -> Save), Splunk reports "Success! Your data is being indexed to Splunk". However, the uploaded file is not available at the selected index. At the server side, i see this log entry at the second when clicking "Save":

splunkd.log
WARN HttpListener - Socket error from 127.0.0.1 while accessing /services/receivers/stream: Broken pipe

Tags (1)
1 Solution

dshakespeare_sp
Splunk Employee
Splunk Employee

The issue was seen for non admin users that tried to add data to Splunk. By adding the "edit_tcp" capability to the users role, the error disappeared and uploaded data gets indexed.

View solution in original post

dshakespeare_sp
Splunk Employee
Splunk Employee

The issue was seen for non admin users that tried to add data to Splunk. By adding the "edit_tcp" capability to the users role, the error disappeared and uploaded data gets indexed.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...