Getting Data In

After configuring Splunk SSO with Siteminder for my application, why are REST API commands not working in Internet Explorer?

Motivator

Hi All,

I have configured Splunk SSO configuration with siteminder for my application. All the siteminder configurations and splunk configurations looks fine, and I am able to access my application via siteminder URL without any error in Mozilla, but when comes to Internet explorer i am not able to see any data in the drop-downs.

My drop-downs will use the REST API interface commands to list different roles based on the user login, but this is not working in internet explorer. By the way, the Splunk version I am using is 6.2.2 and Internet explorer version is 11.

REST API command which is not in working in I.E alone is

| rest /services/authentication/current-context | table username,roles 

Is there any configuration or cache issue with internet explorer? The same is working fine in Mozilla.

Any help on the above scenario would be appreciated.

Thanks,
Rakesh.

0 Karma

Splunk Employee
Splunk Employee

Issue appears to be with site-minder sending an unsupported case for "Content-Type". Site-minder sends "Content-type' with small "t" and this was not supported by XHR requests being made by Splunk. In version 6.2.6 we have added support for this.

0 Karma

Motivator

Not only rest-api search command . even a simple dashboards with a search is not displaying anything..its showing the message populating the search ... etc .but giving me any search results.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!