Deployment Architecture

Troubles installing SplunkWAS onto a UniversalForwarder

jeremiahc4
Builder

I can't seem to get past step one of the instructions for installing SplunkWAS. I get the files unzipped/untarred into the correct directory and restart Splunk. I can see the application at https://splunkforwarder.server.net:8089/services/apps/local/SplunkWAS. However there is where the documentation parts ways with what's happening. There is no interface on the UniversalForwarder server on port 8000, therefore the quoted URL "http://:8000/en-US/manager/search/apps/local" doesn't answer on the network.

Is SplunkWAS only setup to work with full indexer servers or have I wandered off course in some other way?

1 Solution

ekost
Splunk Employee
Splunk Employee

Splunk for WAS has recently been upgraded. Please review the documentation on the new app. Splunk for WAS is now a 3-component installation for full WAS data collection. The Splunk Universal forwarder is typically used to forward log and configuration data from individual WAS machines to an indexer, but not to collect JMX performance data.
The WAS Forwarder Add-on docs can be found here:
link:WAS Forwarder Add-on
There is no validation step while installing a forwarder that would require a view into the SplunkWeb UI.

View solution in original post

ekost
Splunk Employee
Splunk Employee

Splunk for WAS has recently been upgraded. Please review the documentation on the new app. Splunk for WAS is now a 3-component installation for full WAS data collection. The Splunk Universal forwarder is typically used to forward log and configuration data from individual WAS machines to an indexer, but not to collect JMX performance data.
The WAS Forwarder Add-on docs can be found here:
link:WAS Forwarder Add-on
There is no validation step while installing a forwarder that would require a view into the SplunkWeb UI.

View solution in original post