Deployment Architecture

Splunk DB Connect: How to fix Java Bridge Server error "Unable to listen on localhost:17865: java.net.BindException: Address already in use"?

Ashish_Singla
Engager

This is the error I see in _internal index logs

main:FATAL:JavaBridgeServer - Unable to listen on localhost:17865: java.net.BindException: Address already in use
java.net.BindException: Address already in use
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:376)
    at java.net.ServerSocket.bind(ServerSocket.java:376)
    at java.net.ServerSocket.<init>(ServerSocket.java:237)
    at com.splunk.bridge.JavaBridgeServer.run(JavaBridgeServer.java:140)
    at java.lang.Thread.run(Thread.java:745)

Please suggest how it can be solved

1 Solution

MuS
SplunkTrust
SplunkTrust

Hi Ashish_Singla,

the port 17865 is already taken by another process. Change it in the java.conf http://docs.splunk.com/Documentation/DBX/1.1.6/DeployDBX/javaspec inside the DBX app.
It should be located at $SPLUNK_HOME/etc/apps/dbx/local/

cheers, MuS

View solution in original post

MuS
SplunkTrust
SplunkTrust

Hi Ashish_Singla,

the port 17865 is already taken by another process. Change it in the java.conf http://docs.splunk.com/Documentation/DBX/1.1.6/DeployDBX/javaspec inside the DBX app.
It should be located at $SPLUNK_HOME/etc/apps/dbx/local/

cheers, MuS

shekhar_mathur
New Member

Thanks,
The problem is resolved by specifying a new port for java bridge.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...