Deployment Architecture

Scripted splunkforwarder deployment: FAILED: Error updating configuration.

ssbarnea
Explorer

Deployment fails with the error: FAILED: Error updating configuration.

The command being executed is
"/opt/splunkforwarder/bin/splunk" set deploy-poll "mymachine.example.com:8089" --accept-license --answer-yes --auto-ports --no-prompt

This command is part for the example deploy script provided by splunk.

Tags (1)
0 Karma

jgedeon120
Contributor
/opt/splunkforwarder/bin/splunk start --accept-license --answer-yes --auto-ports --no-prompt
/opt/splunkforwarder/bin/splunk set deploy-poll mymachine.example.com:8089 -auth admin:changeme
/opt/splunkforwarder/bin/splunk enable boot-start
/opt/splunkforwarder/bin/splunk edit user admin -password $PASSWORD -auth admin:changeme
/opt/splunkforwarder/bin/splunk restart

Is what I use in my script

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...