Deployment Architecture

SSL to License Master?

mikelongley
Engager

Hi,

We run a distributed architecture in which we have organisations connecting in to our license master, and one organisation has been having trouble connecting. We checked the usual network troubleshooting and it seems fine, and I eventually found a line in the splunkd log suggesting an SSL error:

"WARN HttpListener - Socket error from X.X.X.X:Y while idling: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol"

 

So I didn't think license management traffic actually had an SSL option in the first place, and can't see any reference to it in Splunk's SSL documentation. Has anyone seen any similar errors or have any idea how it might be resolved?

 

Thanks,

Mike

0 Karma

jcaceres
Explorer

unknown protocol indicates that the connecting client is sending a SSL request that the Splunk server doesn't understand.

Check your output of 

splunk btool server list --debug sslConfig

and reference the Splunk docs @isoutamo  provided for supported SSL protocols.

0 Karma

isoutamo
SplunkTrust
SplunkTrust
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...