Deployment Architecture
Highlighted

Help setting up a deployment server

Path Finder

Hi, I am having difficulty setting up a deployment server which serves 2x light fowarders. I beleive I have set up the conf files correctly?

deploymentclients.conf (on the fowarders)

[deployment-client]
disabled = false

[target-broker:deploymentServer]
targetUri = myServerName:8089

serverclass.conf (on the deployment server)

[serverClass:global]
whitelist.0=*

[serverClass:lightforwarders]
whitelist.0=*

[serverClass:lightforwarders:app:SplunkLightForwarder]
stateOnClient=enabled
restartSplunkd=true

Is there anything else I need to do to make the server a deployment server (I couldnt find any directions, so I assumed all I need is the serverclass.conf). The same goes for the deployment clients, are there any settings or commands that need to be run to make them clients?

When I run ./splunk list deployment-clients, it says no clients have contacted the server.

If anyone could write some instructions, that would be much appreciated.

Cheers

0 Karma
Highlighted

Re: Help setting up a deployment server

Contributor

Everytime you modify the serverclass.conf file on your deployment server you need to run the following command for the changes to take effect:

/opt/splunk/bin/splunk reload deploy-server

You can then do

/opt/splunk/bin/splunk list deploy-clients 

on the deployment server to see if your light forwarders are reporting in.

Also make sure that your deployment app is in /opt/splunk/etc/deploymentapps.

Hope that helps.

B

View solution in original post

0 Karma
Highlighted

Re: Help setting up a deployment server

Contributor

You may also be prompted credentials. You should be able to use the same credentials as that of your indexer GUI login if you have admin privileges.

0 Karma
Highlighted

Re: Help setting up a deployment server

Path Finder

Turned out to be a firewall problem. thanks

0 Karma